Thanks for reaching out and shopping with us! πŸ›’πŸŽ΅

All of our packs contains Serum presets, which require an up to date version of the Serum digital synthesizer to use.

If you are getting an error message that you need a more recent version of Serum, then you'll need to update your VST in order to use the product.

This problem can be easily solved by downloading the latest update of Serum by signing into your account on xferrecords.com or Splice.

Note: If you think that you already have the current version, please check again as Serum updates have been known to frequently come out.

If you are still experiencing issues installing the product, please refer to the Xfer Records support that can be found here: https://support.xferrecords.com.